Echo & Alexa User Discussions and Support Forums

When a person is not breathing, permanent brain damage begins after 4 minutes and death in 6 minutes after that. Can you count on help arriving before that time? Learning proper CPR techniques is easy and you can learn it in 30 minutes at CPR Test Center.

Alexa just does not work...help!!

0 Members and 1 Guest are viewing this topic.

Alexa just does not work...help!!
« on: April 02, 2019, 12:56:23 pm »
Right so basically I bought a new Echo Plus 2nd generation after my Echo 1st generation broke. When I set it up to connect to my WiFi, it worked perfectly for about 30 minutes. Then I noticed it restarted itself (as in when it reconnects to power although I had never unplugged it) and from then on, every time I say 'Alexa', it says 'Sorry, I'm having trouble understanding right now...'.
There's a couple weird things with this:
1. I already got a replacement Echo Plus to see if it was the actual device. It wasn't; the replacement still doesn't work.
2. I can still connect to the Echo Plus through Spotify Connect and play music?! So it is connected to WiFi, but it still won't let me ask anything or ask the date or time, etc.
3. The app allows me to control its volume, so I'm assuming it still has the connection to the WiFi.
4. I connected the Echo to my personal hotspot and it worked fine! So it obviously must be a problem with my router...

I've tried everything; I've reset both the Echo Plus and my router to factory settings and I've redownloaded the app, among other things.
I think, as above, there's an obvious problem between the Alexa service's connection to my router. Admittingly, it has slow bandwidth (2.5mbps!!) , but there was never a problem with my previous Echo. Maybe there's been a software change in the way it connects to the internet between the 1st Gen and 2nd Gen?
I'm wondering if anyone can help me with this and suggest any fixes; I've looked everywhere on the Web and nothing seems to help!

Thanks in advance

Re: Alexa just does not work...help!!
« Reply #1 on: April 02, 2019, 02:09:09 pm »
It sounds to me you need to upgrade your router, and/or modem as well as get improved internet service; i.e. faster. Your Alexa device appears fine.

Re: Alexa just does not work...help!!
« Reply #2 on: April 02, 2019, 04:49:03 pm »
give the router brand and model number.

Re: Alexa just does not work...help!!
« Reply #3 on: April 03, 2019, 05:42:02 am »
give the router brand and model number.
Router brand is BT Home Hub 4 (Type A)

Re: Alexa just does not work...help!!
« Reply #4 on: April 03, 2019, 05:43:13 am »
It sounds to me you need to upgrade your router, and/or modem as well as get improved internet service; i.e. faster. Your Alexa device appears fine.
Yeah I thought so... however I still can't see how 2.5mbps could be too slow for the Alexa service (I know its slow but not THAT slow) - my old one worked fine anyway, so I'm still a bit confused :/

Re: Alexa just does not work...help!!
« Reply #5 on: April 03, 2019, 04:57:21 pm »
give the router brand and model number.
Router brand is BT Home Hub 4 (Type A)

thanks,   it is not that old so it should not be a problem.  maybe check to see if it has the latest firmware updates.

if you had not done so, try unplugging the power to your modem, your router and your echo.  use power cable, not on/off switch.

Plug in the modem, wait for it to become available, plug in the router, wait for it to become available, then plug in the echo.