Echo & Alexa User Discussions and Support Forums

General Category => Amazon Echo Discussion => Topic started by: viveiroscordeiro on July 26, 2019, 08:27:31 am

Title: Contact sensor not triggering routine
Post by: viveiroscordeiro on July 26, 2019, 08:27:31 am
Hi,
I have Hassio + Home Assistant Cloud + Alexa
I was able to have exposed virtual and real contact sensors from Home Assistant to Alexa. All the contact sensors are seen by Alexa and report almost intactly the state: “open” or “closed”.

But they are unable to trigger any routine, in fact one of them worked only one first time, triggering the routine, but now although they status on Alexa change correctly from “closed” to “open” the routine is not triggered… (The routine is enabled and can be triggered correctly by the play button on the app)

Is this any known issue?

Thanks!
Title: Re: Contact sensor not triggering routine
Post by: StevenR on July 26, 2019, 12:05:16 pm
I've had a similar issue with Home Assistant Cloud. I don't actually have a contact sensor, but I have a template sensor which is exposed to Alexa as a door sensor and found that it stopped working after a while.
I eventually discovered that it seemed to correspond with restarting Home Assistant. It seems that, following the restart, it stopped reporting the sensor states either though the "Enable State Reporting" was enabled under Configuration > Home Assistant Cloud > Alexa. Disabling and re-enabling this option fixes it for me.
Title: Re: Contact sensor not triggering routine
Post by: bazhig on July 27, 2019, 02:54:15 pm
There is a problem with contact sensors and routines. Mine have stopped working.
Title: Re: Contact sensor not triggering routine
Post by: StevenR on August 25, 2019, 09:05:41 am
I submitted a fix for this issue when using Home Assistant, and this was included in Home Assistant 0.97. This is now working for me even following a restart.