Echo & Alexa User Discussions and Support Forums

When a person is not breathing, permanent brain damage begins after 4 minutes and death in 6 minutes after that. Can you count on help arriving before that time? Learning proper CPR techniques is easy and you can learn it in 30 minutes at CPR Test Center.

Broadlink RM2

0 Members and 1 Guest are viewing this topic.

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #150 on: November 20, 2017, 09:35:59 pm »
Hi sorry for the late reply I have been on holiday. I tried the steps you sent me and had no joy, I ended up buying a echo dot for my bedroom and now it works. Seems to be the software on the echo plus. No I can control my devices from from both devices 👏. Thanks everyone for your help.

Glad to know it works on echo dot. That's what I'm using.

From what I read about the new echo plus, the built-in hub is ZigBee compatible only. RM plugin helps you to bridge the RM PRO as your hub and it can use both RF (what ZigBee uses) as well as IR.

Unless there's a way to disable the built-in ZB hub, it's unlikely to work with RM plugin. This is my current view but hey I'm not the app developer  ;)

Update: I re-read your post again and understood even the echo plus is now working with RM plugin but only after u added an echo dot to your setup. Not sure why this is so but maybe if you try to recall what exactly did you do, maybe that's the "ureka solution" that everyone here is looking for  ;D
« Last Edit: November 20, 2017, 09:51:23 pm by tthoben »
Echo Dot @ SG

Re: Broadlink RM2
« Reply #151 on: November 24, 2017, 01:25:00 pm »
Hello there,

I've been using a Broadlink RM Pro the last couple of weeks. Set-up remotes in e-control, TV, Audio, smart plugs. Yesterday I noticed there were multiple instances of some buttons showing up in RM Tasker plugin. I deleted all codes from RM plugin. After that I tried to import the codes again from e-contol, activated "Share to other phones in WLAN and waited for RM plugin to import, I even pressed on "Force import data from e-control" just to be sure. Yet the codes don't show up in RM plugin. I went on and activated "Debug log to file"; Here's one line of the log:

1511474438091,2017.11.23 23:00:38.091,DEBUG,RMPlugin,Thread: Thread-323,DataManager.saveCodeInfoModelToLocal  (DataManager.java:554),CodeInfo removed: Play • Total: 14

This line keeps repeating for every code Ive deleted.

TL;DR Looks to me like the codes are being imported and removed right away. I've already reinstalled e-control and RM plugin from my Phone (S7) and cleared cache and and data. I also reset my Broadlink. Nothing helped, same issue, codes aren't imported or imported and removed right away.

Does anyone have an idea how to fix this?

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #152 on: November 24, 2017, 04:33:14 pm »
Have u tried contacting the RM tasker developer? My experience is that he respond within a day or two.
Echo Dot @ SG

Re: Broadlink RM2
« Reply #153 on: November 24, 2017, 05:06:29 pm »
Have u tried contacting the RM tasker developer? My experience is that he respond within a day or two.

I just contacted him. Thanks for the advice :)

Re: Broadlink RM2
« Reply #154 on: December 02, 2017, 07:21:14 am »
Hi all - good to find this group & post.

I have the exact same issue and pretty much the same setup down to the Virgin Superhub router. Everything was setup when I was using the first generation Echo but stopped working when I replaced it with a new, second gen Echo.

I have been trying for the last 2 weeks and even after resetting/clearing back to scratch my multiple Android devices (Nexus 5x, Mexus 9, Pixel XL), resetting the Broadlink RM Pro, resetting Echo, setting up static IP address and so on - NOTHING WORKS and Echo discovery fails at the last stage ("Alexa requested individual device info").

Initially, I thought somehow the new gen Echo might be breaking things but another user has got the similar setup working fine.!!!

Not sure where the issue could be and am at my wits end tbh.... the RM PRo plugin developers do not have any support and nowhere else that seems to be reporting this issue (until I saw this forum).

Hoping that someone in here will be able to point in the right direction to a solution.
cheers

Quote
-----------------------------------------------

Steps to setup Alexa Bridge (RM Plugin)

1) set static IP address for each of your device (i.e. echo/dot, RM Pro, android box) in your router settings
2) purchase and install the paid version thru the Google Play Store, not the lite version which expires in 7 days and become unusable
3) ensure that your android box does not go to sleep (disable all screensavers, power saving modes)
4) ensure that the app is running (tapping back may exit the app, tap home instead to get back to home screen)
5) tick the options "enable Alexa Bridge", "Autostart on Boot", "Keep Screen On for HTTP/Alexa Bridge"

If the above are done and discovery still fails, then likely the solution is to reconfigure your Alexa devices on the android box itself:
a) select "Alexa Device List"
b) delete all devices that were imported (swipe left to delete)
c) select "+ADD ALEXA DEVICE" button below and manually create each Alexa Device Name, On and Off Commands (note that the commands are essentially the codes that you imported from the Broadlink app)
d) while doing that, you will be able to test the On and Off Commands before you save
e) if testing here works, congrats it will work eventually
f) once all the Alexa Devices are configured, ask Alexa to discover devices
g) if step (f) fails try using web interface ( alexa.amazon.com ) under SMART HOME > devices > discover


-----------------------------------------------

I have to say, even before I start working through these steps, I'm not hopeful of success.

My network setup is pretty standard, but I do use US Amazon account with my Echo in the UK, so I'm unsure if this influences anything on the firmware/compatibly side of things.

The problem I'm getting is that RM Plugin is detecting a request from Alexa, but fails on the final step of getting device info.

I've tried it using a different router and even with a different Android device but it all falls at the last hurdle.

Having Googled the error message I'm getting, it seems to be an uncommon issue.

I'm going to give it another go tonight!

RDT

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #155 on: December 02, 2017, 11:56:41 pm »
Hi all - good to find this group & post.

I have the exact same issue and pretty much the same setup down to the Virgin Superhub router. Everything was setup when I was using the first generation Echo but stopped working when I replaced it with a new, second gen Echo.

I have been trying for the last 2 weeks and even after resetting/clearing back to scratch my multiple Android devices (Nexus 5x, Mexus 9, Pixel XL), resetting the Broadlink RM Pro, resetting Echo, setting up static IP address and so on - NOTHING WORKS and Echo discovery fails at the last stage ("Alexa requested individual device info").

Initially, I thought somehow the new gen Echo might be breaking things but another user has got the similar setup working fine.!!!

Not sure where the issue could be and am at my wits end tbh.... the RM PRo plugin developers do not have any support and nowhere else that seems to be reporting this issue (until I saw this forum).

Hoping that someone in here will be able to point in the right direction to a solution.
cheers

Firstly, I had good experience when I emailed the rm tasker developer with my problems. So maybe you should try emailing him but have you first tried the troubleshooting macro in the app?

Secondly, I would think that it is a better idea to add the new echo devices into your setup than to remove/replace them. As your setup was already working, what you should have done was to add them into your Alexa account without upsetting the existing setup.

The setup is a once-off process, regardless of the number of echo devices you have. Subsequent adding of echo devices should be done carefully and tested before attempting to redo the setup.

I intend to add a new echo spot to my existing setup. Instead of removing my existing echo dots, I will probably just relocate one of them to my kitchen which is currently not covered.

Maybe what u can do is try to redo the setup using your old echo dot. Once tested working, then add and test the new echo devices
« Last Edit: December 02, 2017, 11:58:23 pm by tthoben »
Echo Dot @ SG

Re: Broadlink RM2
« Reply #156 on: December 03, 2017, 04:32:30 am »
Thanks for the respone TTHOBEN and tips.

Tasker? I emailed the "support@originally.us" email given in RM Plugin - Tasker & Originally are 2 separate/different developer companies. I have also tried the troubleshooting app countless times and as mentioned it always fails at the "individual device info last step". I have opened all UDP ports etc in case the route was the issue.

I did not have an option of trying both Echo devices. I gave away my old one and then purchased the new second gen Echo. With hindsight I should have kept both which would have assisted in getting to the bottom of this.

cheers

Firstly, I had good experience when I emailed the rm tasker developer with my problems. So maybe you should try emailing him but have you first tried the troubleshooting macro in the app?

Secondly, I would think that it is a better idea to add the new echo devices into your setup than to remove/replace them. As your setup was already working, what you should have done was to add them into your Alexa account without upsetting the existing setup.

The setup is a once-off process, regardless of the number of echo devices you have. Subsequent adding of echo devices should be done carefully and tested before attempting to redo the setup.

I intend to add a new echo spot to my existing setup. Instead of removing my existing echo dots, I will probably just relocate one of them to my kitchen which is currently not covered.

Maybe what u can do is try to redo the setup using your old echo dot. Once tested working, then add and test the new echo devices

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #157 on: December 03, 2017, 05:48:49 am »
Thanks for the respone TTHOBEN and tips.

Tasker? I emailed the "support@originally.us" email given in RM Plugin - Tasker & Originally are 2 separate/different developer companies. I have also tried the troubleshooting app countless times and as mentioned it always fails at the "individual device info last step". I have opened all UDP ports etc in case the route was the issue.

I did not have an option of trying both Echo devices. I gave away my old one and then purchased the new second gen Echo. With hindsight I should have kept both which would have assisted in getting to the bottom of this.

cheers

I've the 2nd gen echo dot and it works for sure. So far it seems 2nd gen echo and new echo plus seems unable to work. If I interpreted what user Klumzie2000 said previously, the setup will succeed if you have at least 1 echo dot.
« Last Edit: December 03, 2017, 05:52:23 am by tthoben »
Echo Dot @ SG

Re: Broadlink RM2
« Reply #158 on: December 19, 2017, 07:46:43 am »
Hi,

i have the same problem with my amazon echo, there is no answers from the developer for days now.

anyone was able to solve the problem of importing the codes from e-contol?

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #159 on: December 19, 2017, 08:07:58 pm »
Hi,

i have the same problem with my amazon echo, there is no answers from the developer for days now.

anyone was able to solve the problem of importing the codes from e-contol?

Can you share more details? On which device did you try to export and import the codes?

For me, I have the e-control and rm tasker apps both installed on my mobile phone and the exporting works seamlessly. On the bridge device (my android box) I also have the rm tasker app installed and within the same app on 2 different devices you can also share the codes.

You can try that out and see if it works
Echo Dot @ SG

Re: Broadlink RM2
« Reply #160 on: December 20, 2017, 02:04:27 am »

Can you share more details? On which device did you try to export and import the codes?

For me, I have the e-control and rm tasker apps both installed on my mobile phone and the exporting works seamlessly. On the bridge device (my android box) I also have the rm tasker app installed and within the same app on 2 different devices you can also share the codes.

You can try that out and see if it works

Hi,

I have E-control and rm plugin (i dont have tasker installed) on my Xiaomi phone and i have broadlink rm3 pro.
I have the rm plugin also installed on my android tablet to used it as a bridge device.

when i check in the rm plugin i can see the broadlink pro on both devices but i cant export codes from the app to both devices, i can share the codes i created in the rm plugin between my phone and tablet.

all devices including the amazon echo are connected to the same wifi home network. 

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #161 on: December 20, 2017, 08:23:25 am »
Did u try to "force import data from eControl" under settings/general settings?

Also, it's good to create an account in eControl app and backup your codes in their cloud server in case u need to reinstall the app and restore the codes

Try both and see if it works
Echo Dot @ SG

Offline tthoben

  • *****
  • 113
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #162 on: December 20, 2017, 11:12:48 am »
OK I had time to retry the importing code function and indeed with the latest versions of e-control (3.8.11) and RM plugin (2.2.8 ) this doesn't seem to work for me even when selecting "force import data from eControl". I'm using a Samsung Galaxy S7 edge smartphone with these 2 apps installed.

My only suggestion now is to try downgrading to earlier versions of the apps and see if this importing works. You can find the earlier versions of eControl app here: https://www.apkmonk.com/app/com.broadlink.rmt/#previous and RM Plugin here: https://www.apkmonk.com/app/us.originally.rm_trial/#previous

For those who got the importing to work, can you report the versions of the apps that worked, that should help everyone facing problems and developers not responding quickly enough
« Last Edit: December 20, 2017, 11:17:38 am by tthoben »
Echo Dot @ SG

Re: Broadlink RM2
« Reply #163 on: December 21, 2017, 02:04:55 am »
OK I had time to retry the importing code function and indeed with the latest versions of e-control (3.8.11) and RM plugin (2.2.8 ) this doesn't seem to work for me even when selecting "force import data from eControl". I'm using a Samsung Galaxy S7 edge smartphone with these 2 apps installed.

My only suggestion now is to try downgrading to earlier versions of the apps and see if this importing works. You can find the earlier versions of eControl app here: https://www.apkmonk.com/app/com.broadlink.rmt/#previous and RM Plugin here: https://www.apkmonk.com/app/us.originally.rm_trial/#previous

For those who got the importing to work, can you report the versions of the apps that worked, that should help everyone facing problems and developers not responding quickly enough

yes, i suspected that the new version of the app may cause a problem.

i did try what you suggested yesterday, "force import data from eControl" and backup the codes in their cloud server
even tried a different phone and nothing worked.

Im going to try downgrading the rm plugin app (running 2.2.8 ) and see what will happen.

Re: Broadlink RM2
« Reply #164 on: December 21, 2017, 04:07:52 am »
Hello I'm new here having recently bought an Echo.  Being intrigued by home automation side of things I first got some lighting automated, great fun, and then moved onto the Broadlink VM pro but unfortunately I'm having nothing but problems and having read some of the more recent posts in this thread my problems seem to be a common thing.

Firstly E-Control app and Tasker refuse to talk.  Using the latest versions of both tasker will not import devices from E-Control (tried force import, no difference).  I downloaded version 2.02 from a 3rd party source and this works but in doing so this version installs as a trial and will stop working in 7 days?  Is there any workaround for this? 

Secondly, and more importantly, the Echo will not see any new devices no matter what I do.  I'm using my Samsung S7 phone and to be honest I'm starting to think that is the problem.  Running the trouble shooting wizard shows that the echo is broadcasting, the phone responds, echo requests device descriptor XML and then the phone doesn't respond getting stuck at Alexa requested individual device info.  I get the impression that the phone is blocking something here.  I don't think its my wifi setup as surely if it was it wouldn't get this far before failing? 

I'm going to try and get a generic android tablet to test this on.  Its just a shame I cannot get the app from the amazon store or I'd just run it on my fire stick. 

I notice some saying this app doesn't work with the echo 2 and only the echo dot?  Are they not both identical pieces of hardware / software with the only difference being a speaker?  I would be keen to get some solid confirmation on this point as if this is the case then I will simply send the broadlink back.