Echo & Alexa User Discussions and Support Forums

When a person is not breathing, permanent brain damage begins after 4 minutes and death in 6 minutes after that. Can you count on help arriving before that time? Learning proper CPR techniques is easy and you can learn it in 30 minutes at CPR Test Center.

Broadlink RM2

0 Members and 1 Guest are viewing this topic.

Re: Broadlink RM2
« Reply #75 on: April 05, 2017, 04:02:56 pm »
Hi all

Im running on an android box and its a bit up and down. Especially when registering new devices.

Running from an Android 4.2.2 box, alexa dot and rm-pro. At the bottom o the page im seeing this:

There are 0/1 servers (25 devices) ative in the Alwxa Brige on interface...etc.

Prior to tonight's device list update I had '1/1 servers', any idea how to get this back? I've rebooted wi-fi, rm plugin, etc but no joy.

Thanks in advance

Offline tthoben

  • *****
  • 118
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #76 on: April 06, 2017, 09:41:17 am »
There are 0/1 servers (25 devices) ative in the Alwxa Brige on interface...etc.

R u running RM Tasker as the bridge?

Try to set a static IP in your router settings for all your devices, including the echo dot, RM pro. It could be that the IP was refreshed and the bridge app lost the connection
Echo Dot @ SG

Re: Broadlink RM2
« Reply #77 on: May 29, 2017, 08:47:21 am »
Hi everyone,
I am new to this forum. I am German and located in the UK. I am using an account and the British English version of Alexa.

I have had two Echo Dots for a while and I bought the Broadlink RM Pro last week and got the RM plugin app. Everything went fine until I asked Alexa to discover devices. This she can't do.

After ruling out everything else, RM plugin support told me:

"That means Alexa device is totally unable to communicate with your Android device at all.
Since you have already tried 3 different android brands, the only conclusion we can say is there is some settings in your router that blocks UDP broadcast traffic.
This is the protocol that Alexa uses to initially trigger a discovery request."

I am not sure where to go from here. I looked at the browser interface of my router (Asus DSL-N55U) but, being very ignorant of  what most of it means, could not find any clear solution.

Can anyone offer some advice?

Thanks a lot!

Re: Broadlink RM2
« Reply #78 on: June 02, 2017, 02:45:16 am »
I solved the issue. If anyone has similar problems in the future (I am using the RM Pro):

These UDP ports need to be open:


I went into the option "port forwarding" on my browser interface. I also had to put in the IP address of the Android device I am using for RM plugin.

However, Alexa still failed to find the new devices when I gave the voice command. Using the app (Smart Home > Devices > Discover) was much more reliable.

Can anyone recommend an Android TV box or stick which works well with Alexa?

Re: Broadlink RM2
« Reply #79 on: July 19, 2017, 02:50:28 pm »
I downloaded the latest version of e-control today and it linked me to another broadlink bit of software that supports Alexa via a skill and not a bridge. ( Ihc) My joy  was short-lived when I couldn't find the skill due to it being for US and not UK (At the moment?). Can anyone confirm if this finally means the US alexa can access rm pro without an android bridge or do you still need one?

Re: Broadlink RM2
« Reply #80 on: July 20, 2017, 07:16:45 am »
The software is available in the US as is the skill.
I posted about both here:,2262.0.html
you can only control AV devices via Alexa and alexa will not see RF devices configured yet.
So depending on what you use the Broadlink for you may beable to get by with just the skill.

Re: Broadlink RM2
« Reply #81 on: July 20, 2017, 08:30:36 am »
Mmm, hopefully they will add RF before it's available in UK. Thanks

Re: Broadlink RM2
« Reply #82 on: July 20, 2017, 10:17:43 am »
The Alexa Skill wasn't available in North America when I first loaded the IHC app so I emailed the developer asking when it would be released to North America.
The Next day I got a reply and the Skill was there. Not sure if that was just a coincidence but a email to the developer may speed things up for the UK release. ;)

Re: Broadlink RM2
« Reply #83 on: July 20, 2017, 04:24:06 pm »
I've given it a try. Will see what they say.

Re: Broadlink RM2
« Reply #84 on: July 20, 2017, 05:35:17 pm »
The Alexa Skill wasn't available in North America when I first loaded the IHC app so I emailed the developer asking when it would be released to North America.
The Next day I got a reply and the Skill was there. Not sure if that was just a coincidence but a email to the developer may speed things up for the UK release. ;)

The Broadlink skill uses new Entertainment capabilities for Smart Home skills, which allow them to control TVs, AV receivers, and IR hubs, and which are currently only available in the US (Amazon says UK and Germany support is coming soon), so the developer hasn't really got any control over this. Also, the way I understand it, it appears that Amazon don't allow a single Smart Home skill to support both Entertainment devices and other device types (switches, etc.). This is presumably why the Broadlink skill doesn't support RF.

Re: Broadlink RM2
« Reply #85 on: August 01, 2017, 01:47:54 pm »
I was reading this article  (translated) and it does appear that they are planning better integration between broadlink and Alexa

Re: Broadlink RM2
« Reply #86 on: August 09, 2017, 02:10:12 am »
Hi Guys, I'm new to this forum and need some help on my rm2 pro link up with echo dot.
Currently I have all my remote added to rm bridge and working well on web trigger control, smartthings i have created location, device & device handler already input the ip that my android tvbox running rm bridge address and able to find the devices with alexa discovery, also the smartthings skill enabled. I have open the router UDP port 7474, 123, 443, 4070, 40317, 49317, 33434 to the android box running the rm bridge. Now the problem is dot cannot control rm2 pro at all, totally no response. Am I missing anything that smartthings needed to talk with rm bridge?

Device I am using: Echo Dot x 2, RM2 Pro x 2, Asus RT-AC88U, RM Bridge.

Re: Broadlink RM2
« Reply #87 on: August 16, 2017, 06:08:11 pm »
Just updated to latest version of e-control & all my icons are gone, just place markers. Anybody else have an issue?

It's version 3.8.8-1.3.1

Re: Broadlink RM2
« Reply #88 on: August 16, 2017, 06:27:49 pm »
Reinstalling corrected it  8)

Re: Broadlink RM2
« Reply #89 on: August 17, 2017, 08:42:58 pm »
Hi all,
I am new to your forum so please excuse me if I have posted in the wrong area.  It is a long post so you have an idea of where I am at and where I would like to go with the RM Pro and Alexa...
It is fantastic to see so many people tinkering with Alexa in so many ways...I view her as the standout low level AI currently accessible to people like me.

To give you a bit of an idea where I am currently with AI incorporation into home automation...
I have...
X1 Echo Dot
X1 Broadlink RM Pro
X2 Sonoff 4-gang wifi switches
Multiple iOS devices
Many electronic devices I am endeavouring to control via Alexa with the initial focus being centred on creating speaker 'zones/compartments' throughout my house, man cave and also outside the house.  I enjoy music and for me it is the perfect test bench for voice control home automation.

I am located in Tasmania (small island State at the southern most tip of Australia)...I mention this due to the added technical challenges my geographical location adds to utilising Alexa herself.  Amazon is only just starting to try and enter our country officially and therefore we have zero support and a few technical difficulties when trying to make use of the AI.

As it stands Alexa controls the Sonoff wifi 4-gang switches straight out of the box.  They are incredibly cheap and as they can handle both low volt DC and mains AC they are perfect for many applications.  Thier primary use for me to begin with is to switch on/off pairs of speakers I have dotted in & around my house.  The relays are extremely low impedance so having the speaker wires directly spliced into the relays doesn't seem to present a problem.  It is worth noting I am running the many varied speakers from a 'middle of the range' Yamaha Amplifier that does have existing capacity for two zones.  However two zones doesn't cover my needs...ERGO my need for creating multiple zones via the Sonoff relays with the added bonus of Alexa doing the background leg work.

I tinkered with Alexa controlling the Yamaha Amplifier through IP commands e.g. XML etc.  but this became overly complicated and required me to do a crash course in coding...bothersome to say the least.

Then I found the Broadlink RM Pro online and purchased one to see how truly 'universal' it was.  To my amazement it immediately did all it was touted as being able to do.  It even learned the codes to control some derivative Chinese branded TV I have sitting in the kitchen...which none of the various Logitech Harmony universal remotes I have owned have ever been able to learn/mimic.

So now I have given you a run down of my situation and my immediate goals I will outline my current situation as it relates to Alexa and the Broadlink RM Pro...

As it stands I am using the latest IHC app in conjunction with the associated e-control broadlink app and Alexa is able to turn on/off etc. my amp (plus my Plasma TV in the same room).  Once I figured out the only way Alexa is able to control a device (any device) is by pretending it is a TV in the app itself and customising/learning the appropriate IR codes for the device such as the Yamaha Amp...I was up and going.

However I am now at the stage I would like to add 'scenes' to Alexa's ability to control devices.  I have 'programmed' scenes in both the IHC app and also the Broadlink e-control app to do something simple e.g. Power on the zone 2 function of the amp, however in the Alexa app itself she can't find any scenes in the smart home section of her skills.  I know the button to turn on the Amps Zone 2 is functional as pressing it in the IHC app GUI works.  The scene I have created in the apps is simply a one step process...initialise this one button that turns Zone 2 on/off.

I would really appreciate any thoughts, suggestions or solutions to this niggling little issue.