Echo & Alexa User Discussions and Support Forums

When a person is not breathing, permanent brain damage begins after 4 minutes and death in 6 minutes after that. Can you count on help arriving before that time? Learning proper CPR techniques is easy and you can learn it in 30 minutes at CPR Test Center.

Alexa App

0 Members and 1 Guest are viewing this topic.

Alexa App
« on: December 29, 2017, 09:11:32 am »
I cannot download the Alexa App to my Samsung tab version 5.0.2.
It says 'Your device isn't compatible with this device'.

Any suggestions please?

Offline GA

Re: Alexa App
« Reply #1 on: December 29, 2017, 10:19:12 am »
Had the same problem, except my Samsung Tablet Android version is 5.0.2.  What I found is that the Alexa App is not compatible with all versions of Android OS, even if it is 5 and above. So, after trying to get help from Amazon, which did not go well, I decided to go back to the version that was running on my Tablet before I tried upgrading. I searched for the old version of the apk and found: https://www.apkmonk.com/app/com.amazon.dee.app/
This place has all the versions. I tried the newest with the same results. I worked back until I found one that worked.
 The one that worked for my tab was the Oct 25 2017. I downloaded and saved that copy, in case I run into this problem again after an update, I will have a baseline.
Hope this helps. Good Luck.

Re: Alexa App
« Reply #2 on: December 29, 2017, 12:04:02 pm »
I cannot download the Alexa App to my Samsung tab version 5.0.2.
It says 'Your device isn't compatible with this device'.

Any suggestions please?
If you have a computer, download the Alexa browser app.

Re: Alexa App
« Reply #3 on: December 29, 2017, 04:32:33 pm »
I cannot download the Alexa App to my Samsung tab version 5.0.2.
It says 'Your device isn't compatible with this device'.

Any suggestions please?
If you have a computer, download the Alexa browser app.

theres an alexa browser app????   I just go to alexa.amazon.com

Re: Alexa App
« Reply #4 on: December 29, 2017, 07:58:32 pm »
Ya when I get not compatible I just install APK like OP did.