Echo & Alexa User Discussions and Support Forums

When a person is not breathing, permanent brain damage begins after 4 minutes and death in 6 minutes after that. Can you count on help arriving before that time? Learning proper CPR techniques is easy and you can learn it in 30 minutes at CPR Test Center.

Intermittent response "That command doesn't work on that device..."

0 Members and 1 Guest are viewing this topic.

I have 48 devices set up using a hue bridge.  Intermittently when issuing an on/off command to any of my devices, I get back "That command doesn't work on that device".  Issuing the exact same command again works as usual with "Ok" returned as a response.  Has anyone else noticed this lately?  I tried forgetting all of my devices and rediscovering them to see if that makes any difference.  I'm wondering if this is a cloud issue or something local...

Chuck

Re: Intermittent response "That command doesn't work on that device..."
« Reply #1 on: January 06, 2016, 06:13:00 am »
Yes, occasionally I experience the same thing.  Not so much with the Hue hub ad in general.  I have no idea why.

Meantime, the last few days I've sensed some funny things going on with Alexa.  Several times I've failed to get a response at all from her, even after trying half a dozen times.  I'm assuming something going on at the cloud level, but that's just a guess.

Re: Intermittent response "That command doesn't work on that device..."
« Reply #2 on: January 06, 2016, 08:39:42 am »
Thanks for the confirmation.  Hopefully it will be fixed soon...

Re: Intermittent response "That command doesn't work on that device..."
« Reply #3 on: January 06, 2016, 07:16:44 pm »
Has anyone approached Amazon about this?  I did via email and got a response suggesting that this wasn't a known issue and I needed to call in for advanced tech support.  It happened MANY times this evening to the point where I gave up and started using the physical switches.  It almost seems that it has to do with busy times of day..,

Offline jwlv

  • *
  • 1022
Re: Intermittent response "That command doesn't work on that device..."
« Reply #4 on: January 07, 2016, 03:12:51 am »
Whatever software update that Amazon pushed out today (or yesterday) broke my entire home automation setup. Whenever I ask Alexa to turn on/off a Wemo device, it says "That command doesn't work on that device."

Re: Intermittent response "That command doesn't work on that device..."
« Reply #5 on: January 09, 2016, 06:25:05 am »
Starting on or about Jan 7 or Jan 8 I'm having the same problem with my Philip Hue bulbs.  Echo says it can't find my group names or that the "command doesn't work with that device". After several failures, things work about 10% of the time. If I reboot The Echo it works but then after 15 minutes the problem returns.  I suggest everyone who has this issue call tech support like I did.  They claim no one else reported this problem.  They spent 45 min troubleshooting with me and then asked permission to pull data from my Echo. They supposed to get back to me on Tuesday.
« Last Edit: January 09, 2016, 06:41:52 am by Cmaffia »

Re: Intermittent response "That command doesn't work on that device..."
« Reply #6 on: January 09, 2016, 06:56:25 am »
Starting on or about Jan 7 or Jan 8 I'm having the same problem with my Philip Hue bulbs.  Echo says it can't find my group names or that the "command doesn't work with that device".

Found this thread on a Google search and signed up to mention I have the same issue. Starting a couple days ago my Hue commands get the same "cannot find a group by that name" response you are seeing.

I have tried everything I can think of. I rebooted the Echo and Hue hub and also removed the Hue device from the Alexa iOS app and paired the Hue again and made new lighting groups... still the same thing.

I'll report this to Amazon today. Hopefully the more of us that report it, will get this issue some attention.

I have noticed this too.  I'm curious if the problems are from the update Philips has pushed out that "fixed" the blocking of non Hue lights.

Sent from my SM-T807V using Tapatalk


Re: Intermittent response "That command doesn't work on that device..."
« Reply #8 on: January 09, 2016, 06:54:22 pm »
It's really bad for me tonight, sometimes having to repeat commands anywhere from 5 to 10 times to get them to work properly.  This seems to be related to load/high traffic times.   I just wish we could get a confirmation from Amazon that they are aware of the issue and are working on resolving it.

I have noticed this too.  I'm curious if the problems are from the update Philips has pushed out that "fixed" the blocking of non Hue lights.

Sent from my SM-T807V using Tapatalk

I don't think so, at least for me. I have the Hue 2.0 bridge and the last update firmware update was December 21, and my Hue lights worked fine with Echo after that. My trouble only started a couple days ago.

I emailed a trouble report for Amazon and they replied they have forwarded this to engineering and asked me to call to discuss further. I plan to do that today.

http://www2.meethue.com/en-us/release-notes/

Please let us know what they say.   Thanks!

Sent from my SM-T807V using Tapatalk


Re: Intermittent response "That command doesn't work on that device..."
« Reply #11 on: January 10, 2016, 12:58:07 pm »
Woot! I got mine sorted out thanks to a tip on Reddit.

My Hue group name setup on the Echo was "living room" and saying "Alexa turn on the living room lights" has always worked. I just tested with "Alexa turn on the living room" and it worked! So I renamed the group in the Alexa iOS app to "living room lights" and now I have my old behavior back and it works every time.

So it looks like Amazon changed something so that it looks strictly for the group name and saying "lights" after the group name breaks it, unless of course you change the group name to include lights at the end like I just did.

Edit: I just saw this blog post linked on Reddit that mentions the same thing I found.

http://betanews.com/2016/01/10/using-amazon-echo-to-control-your-home-theres-a-minor-change-you-need-to-know-about/
« Last Edit: January 10, 2016, 01:34:43 pm by Weaselboy »

Re: Intermittent response "That command doesn't work on that device..."
« Reply #12 on: January 10, 2016, 02:20:25 pm »
Woot! I got mine sorted out thanks to a tip on Reddit.

My Hue group name setup on the Echo was "living room" and saying "Alexa turn on the living room lights" has always worked. I just tested with "Alexa turn on the living room" and it worked! So I renamed the group in the Alexa iOS app to "living room lights" and now I have my old behavior back and it works every time.

So it looks like Amazon changed something so that it looks strictly for the group name and saying "lights" after the group name breaks it, unless of course you change the group name to include lights at the end like I just did.

Edit: I just saw this blog post linked on Reddit that mentions the same thing I found.

http://betanews.com/2016/01/10/using-amazon-echo-to-control-your-home-theres-a-minor-change-you-need-to-know-about/

I'm happy to hear your setup is now working correctly.  That said however, it doesn't explain why many of us are still getting the "That command doesn't work with that device" response.  I really hope Amazon gets to the bottom of this quickly as I don't feel like I can depend on it at this time...

Chuck

Re: Intermittent response "That command doesn't work on that device..."
« Reply #13 on: January 10, 2016, 04:18:55 pm »
when you get "that command does not work" response, did you look in your logs to see what Alexa heard you say?

Re: Intermittent response "That command doesn't work on that device..."
« Reply #14 on: January 10, 2016, 04:41:47 pm »
when you get "that command does not work" response, did you look in your logs to see what Alexa heard you say?

Yes and in each case it's exactly as I spoke it...