Echo (Alexa) User Forums

Broadlink RM2

0 Members and 2 Guests are viewing this topic.

Re: Broadlink RM2
« Reply #135 on: November 08, 2017, 02:07:23 pm »
Hello @tthoben ,
I've been struggling for a week in setting up the rm pro with alexa  and while searching the web for a solution i came across your post, i installed RM plugin and added my devices from econtrol app and when i test the signal it works normally from the RM plug in.
Then i tried to discover my devices in alexa up after enabling alexa bridge but unfortunately i can't find any devices .
Your help is highly appreciated

best regards

Hi I've answered your query too  ;D

Without getting too complicated, you have to understand that the importing of data from eControl app to RM Tasker is essentially the codes. It will only work if the Alexa device is set-up in RM Tasker and using the imported codes.

The learning of codes can also be done within the RM Tasker app while setting-up the Alexa device

@tthoben
I would like to thank you for your help and support , the step by step guide you sent me helped me a lot and now everything is working flawlessly without any problem at all.

thank you again and again

best regards
@tthoben

I am having this problem too. I have the same box as you. I have followed the instructions that you sent to the above person but this is still not working! Any help would be grateful

Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #136 on: November 08, 2017, 02:30:27 pm »
@tthoben

I am having this problem too. I have the same box as you. I have followed the instructions that you sent to the above person but this is still not working! Any help would be grateful

Maybe @Thefox1982 can forward to you the step-by-step guide that I sent to him (sorry I forgot to save a copy to my sent folder :P)
Echo Dot @ SG

Re: Broadlink RM2
« Reply #137 on: November 08, 2017, 02:39:09 pm »
@tthoben

I am having this problem too. I have the same box as you. I have followed the instructions that you sent to the above person but this is still not working! Any help would be grateful

Maybe @Thefox1982 can forward to you the step-by-step guide that I sent to him (sorry I forgot to save a copy to my sent folder :P)

Hey, sent it there. Tried it in full and still not working. I had a previous android box and worked perfectly on that.

Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #138 on: November 08, 2017, 03:13:59 pm »
Hey, sent it there. Tried it in full and still not working. I had a previous android box and worked perfectly on that.

oops sorry I got mixed up I meant geekyxpert  :P

since you got it working before it's likely your problem is the IP of the new box is different from the old one. You will need to follow the steps from the beginning and set-up from scratch. Do fix the static IP from your router settings so that future equipment upgrades will be less of an issue. Reuse the same IP of your old box to ensure maximum compatibility.

FYI, I've since upgraded my android box to XIAOMI MiBOX3S, added/replaced new broadlink smart switches etc. almost everytime I needed to troubleshoot to get everything working again. It's a pain and time-consuming exercise but hopefully what I've learnt can help others
Echo Dot @ SG

Re: Broadlink RM2
« Reply #139 on: November 08, 2017, 03:21:25 pm »
Hey, sent it there. Tried it in full and still not working. I had a previous android box and worked perfectly on that.

oops sorry I got mixed up I meant geekyxpert  :P

since you got it working before it's likely your problem is the IP of the new box is different from the old one. You will need to follow the steps from the beginning and set-up from scratch. Do fix the static IP from your router settings so that future equipment upgrades will be less of an issue. Reuse the same IP of your old box to ensure maximum compatibility.

FYI, I've since upgraded my android box to XIAOMI MiBOX3S, added/replaced new broadlink smart switches etc. almost everytime I needed to troubleshoot to get everything working again. It's a pain and time-consuming exercise but hopefully what I've learnt can help others

I knew that the IP address of the new box would be different and a new RM tasker would be added to the new box, so I click on the forget button for the devices on alexa. I did this so I would start from scratch.

Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #140 on: November 08, 2017, 03:38:48 pm »
I knew that the IP address of the new box would be different and a new RM tasker would be added to the new box, so I click on the forget button for the devices on alexa. I did this so I would start from scratch.

noted, check your PM we take it offline
Echo Dot @ SG

Re: Broadlink RM2
« Reply #141 on: November 08, 2017, 05:11:23 pm »
Hi could anyone help me please!!

I have:

Echo plus
RM pro 2 firmware v20028
Mxq pro android tv box with RM Plugin v2.20 installed.

All connected on 2g via a
Virgin media super hub 2.

I have not been able to discover any devises at all.

RM plugin shows 1/1servers (1 devices)

I have tried the troubleshoot wizard and got an error saying did not receive any discovery request from Alexa.

I have managed today to finally get a step closer and using the troubleshoot wizard it received a discovery request and then response with device descriptor and so on until I got an error saying did not receive individual device request.

Could anyone please help it's been driving me mad and sure I'm missing something simple

Thanks in advance for any help


Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #142 on: November 08, 2017, 07:12:55 pm »
Hi could anyone help me please!!

I have:

Echo plus
RM pro 2 firmware v20028
Mxq pro android tv box with RM Plugin v2.20 installed.

All connected on 2g via a
Virgin media super hub 2.

I have not been able to discover any devises at all.

RM plugin shows 1/1servers (1 devices)

I have tried the troubleshoot wizard and got an error saying did not receive any discovery request from Alexa.

I have managed today to finally get a step closer and using the troubleshoot wizard it received a discovery request and then response with device descriptor and so on until I got an error saying did not receive individual device request.

Could anyone please help it's been driving me mad and sure I'm missing something simple

Thanks in advance for any help

Hi, is echo plus the new model with built in smart hub? I've not seen or heard anyone successfully integrated with this new model. Assuming u did setup your devices correctly and still could not discover them, your best bet would be to contact the rm plugin developer for help
Echo Dot @ SG

Re: Broadlink RM2
« Reply #143 on: November 09, 2017, 06:10:51 am »
Hi thanks for the reply, yes it the new echo with built in hub. i have tried contacting RM about it and have not received a reply. I think it is possible as I have managed to get them to start communicating with each other but falls at the last hurdle. Just can figure it out.
« Last Edit: November 09, 2017, 06:17:24 am by Klumzie2000 »

Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #144 on: November 09, 2017, 07:38:27 pm »
Hi thanks for the reply, yes it the new echo with built in hub. i have tried contacting RM about it and have not received a reply. I think it is possible as I have managed to get them to start communicating with each other but falls at the last hurdle. Just can figure it out.

I will fwd you the steps which I shared with the others which worked. If it doesn't do it for you, maybe the problem lies elsewhere i.e. incompatibility with new Echo products
Echo Dot @ SG

Offline RDT

Re: Broadlink RM2
« Reply #145 on: November 19, 2017, 06:49:39 pm »
Hi thanks for the reply, yes it the new echo with built in hub. i have tried contacting RM about it and have not received a reply. I think it is possible as I have managed to get them to start communicating with each other but falls at the last hurdle. Just can figure it out.

I will fwd you the steps which I shared with the others which worked. If it doesn't do it for you, maybe the problem lies elsewhere i.e. incompatibility with new Echo products

Perhaps you could post the steps publicly?

I知 having the same problems of Alexa not finding new devices and I知 wondering if it痴 because I知 using the latest generation Echo.

Thanks

Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #146 on: November 20, 2017, 01:37:48 am »
Perhaps you could post the steps publicly?

I知 having the same problems of Alexa not finding new devices and I知 wondering if it痴 because I知 using the latest generation Echo.

Thanks

Check your PM
Echo Dot @ SG

Re: Broadlink RM2
« Reply #147 on: November 20, 2017, 07:26:43 am »
Hi sorry for the late reply I have been on holiday. I tried the steps you sent me and had no joy, I ended up buying a echo dot for my bedroom and now it works. Seems to be the software on the echo plus. No I can control my devices from from both devices 👏. Thanks everyone for your help.
« Last Edit: November 20, 2017, 10:18:02 am by Klumzie2000 »

Offline RDT

Re: Broadlink RM2
« Reply #148 on: November 20, 2017, 12:18:26 pm »
Thanks to tthoben for sending me the details by PM.

I hope he doesn't mind me reposting it here, I'm sure it'll help lots of people! 
 
-----------------------------------------------

Steps to setup Alexa Bridge (RM Plugin)

1) set static IP address for each of your device (i.e. echo/dot, RM Pro, android box) in your router settings
2) purchase and install the paid version thru the Google Play Store, not the lite version which expires in 7 days and become unusable
3) ensure that your android box does not go to sleep (disable all screensavers, power saving modes)
4) ensure that the app is running (tapping back may exit the app, tap home instead to get back to home screen)
5) tick the options "enable Alexa Bridge", "Autostart on Boot", "Keep Screen On for HTTP/Alexa Bridge"

If the above are done and discovery still fails, then likely the solution is to reconfigure your Alexa devices on the android box itself:
a) select "Alexa Device List"
b) delete all devices that were imported (swipe left to delete)
c) select "+ADD ALEXA DEVICE" button below and manually create each Alexa Device Name, On and Off Commands (note that the commands are essentially the codes that you imported from the Broadlink app)
d) while doing that, you will be able to test the On and Off Commands before you save
e) if testing here works, congrats it will work eventually
f) once all the Alexa Devices are configured, ask Alexa to discover devices
g) if step (f) fails try using web interface ( alexa.amazon.com ) under SMART HOME > devices > discover


-----------------------------------------------

I have to say, even before I start working through these steps, I'm not hopeful of success.

My network setup is pretty standard, but I do use US Amazon account with my Echo in the UK, so I'm unsure if this influences anything on the firmware/compatibly side of things.

The problem I'm getting is that RM Plugin is detecting a request from Alexa, but fails on the final step of getting device info.

I've tried it using a different router and even with a different Android device but it all falls at the last hurdle.

Having Googled the error message I'm getting, it seems to be an uncommon issue.

I'm going to give it another go tonight!

RDT

Offline tthoben

  • *****
  • 103
  • Greetings from sunny Singapore!
Re: Broadlink RM2
« Reply #149 on: November 20, 2017, 09:26:39 pm »
I have to say, even before I start working through these steps, I'm not hopeful of success.

My network setup is pretty standard, but I do use US Amazon account with my Echo in the UK, so I'm unsure if this influences anything on the firmware/compatibly side of things.

The problem I'm getting is that RM Plugin is detecting a request from Alexa, but fails on the final step of getting device info.

I've tried it using a different router and even with a different Android device but it all falls at the last hurdle.

Having Googled the error message I'm getting, it seems to be an uncommon issue.

I'm going to give it another go tonight!

RDT

The US/UK settings will affect your Amazon music playback so that needs to be resolved in due course (but is unlikely to be cause of your current problem).

For RM plugin, you should refer to the in-app troubleshooting guide. Certain routers are known to be incompatible and there may be workarounds (or not) as informed by the app developer. If you have paid for the app, do get the help from the developer.

Lastly, you should read the other posts that echo plus doesn't work (unless someone got it to work and post the how-to steps here).
« Last Edit: November 20, 2017, 09:41:14 pm by tthoben »
Echo Dot @ SG